Broken again.

Upon setting verification, everything was verified except Safari 6.0. Tried to launch Safari 5.0 but failed. Mountain Lion does NOT allow older version of Safari to launch.

Failed.

So switched Firefox 3.x (Sorry, I forgot). It couldn’t even get pass the verification page.

So, nope, doesn’t work…again. I just hope that IRD will make it compatible with Safari 6.0 by the time we have to report tax for next year.